Notes on Networking

A blog to share my study notes on Cisco networking and more

BGP LAB Scenario

Mar
15

This scenario is made in GNS3 to practice BGP concepts and configurations: Local Preference, MED, Weight, AS Prepending, BGP Community, Aggregation, Route Reflectors and etc.

For all ASes:

  • For router Rx, the IP addresses of internal links are in the 10.[AS].[xy].[x] format and  the IP addresses of external links are in the 192.168.[xy].[x] format.
  • EIGRP is used as the IGP routing protocol.
  • Internal BGP neighborship is formed using the IP address of loopback 0 interface and external BGP neighborship is formed using the IP address of outgoing interface.
  • AS border routers modify the next hop IP address to self IP address.
  • AS border routers consider BGP security features: ttl-security and

 

AS 10:

  • AS 10 hosts the 172.10.0.0/22 prefix.
  • Router R3 and R4 are configured as Route Reflectors They peer with each other via standard IBGP and with the clients using the neighbor route-reflector-client statement.
  • Router R3 and R4 use peer-group to simplify the configuration.
  • POLICY 10-1: The administrator wants the traffics coming from AS 30 and destined to AS 10 to come in through router R2 and not R1. For this purpose router R1 and R2 modify the MED parameter as an outbound policy in order to influence the incoming traffics from AS 30.
  • POLICY 10-2: The administrator wants to give an option to remote ASes to tell how to route traffics towards them. For this propose routers in AS 10 modify Local Preference parameter according to customer configurable Community values as an inbound policy in order to influence the outgoing traffics.

 

  AS 20:

  • AS 20 hosts the 172.20.0.0/22 prefix.
  • Router R11 is not running BGP.
  • Router R9 and R10 originate default route to the rest of the AS routers.
  • POLICY 20-1: AS 20 should not be a transit for any of its neighbouring ASes. For this purpose router R9 and R10 use filter-list in order to prevent external routes learned from one AS from being advertised to another AS.
  • POLICY 20-2: The administrator wants the outgoing traffics destined to AS 30 to go through AS 40 and not AS 10. For this purpose router R9 and R10 modify the Local Preference parameter as an inbound policy in order to influence the outgoing traffics destined to AS 30.

 

AS 30:

  • AS 30 hosts the 172.30.0.0/22 prefix.
  • Router R7 originates a default route to AS 65001.
  • Router R7 originates only an aggregate route for its prefixes and suppresses the more specific routes.
  • Router R7 removes private AS numbers from the AS_PATH of routes before advertising them to AS 10 and AS 40.
  • POLICY 30-1: The administrator wants the incoming traffics destined to AS 30 to come from AS 10 and not AS 40. For this purpose router R7 does AS-Path Prepending as an outbound policy in order to influence the incoming traffics destined to AS 30.

 

AS 40:

  • AS 40 hosts the 172.40.0.0/22 prefix.
  • POLICY 40-1: The administrator wants the outgoing traffics destined to AS 20 to utilize the link to router R9. For this purpose router R8 modifies the Weight parameter as an inbound policy in order to influence the outgoing traffics destined to AS 20.
  • POLICY 40-2: The administrator wants to control routing policies in the upstream service provider network (in this scenario AS 10) in order to influence the incoming traffics from AS 10 destined to AS 40. For this purpose router R8 sends signal to AS 10 using Community attributes as an outbound policy in order to influence the incoming traffics from AS 10 to go through AS 30 to reach AS 40 and not through the direct link to AS 10.

 

AS 65001:

  • AS 65001 is a private AS that is only connected to AS 30.
  • AS 65001 hosts the 172.30.3.0/24 prefix which is a portion of AS 30’s address space.
  • AS 65001 also hosts 172.65.0.0/24 prefix but sets no-export community for this prefix when advertising it to AS 30 in order to prevent AS 30 from advertising this prefix to the rest of the internetwork.
  • AS 65001 only accepts a default route from AS 30.

 

Configuration:

R1:

hostname R1

 

interface Loopback0

 ip address 10.10.0.1 255.255.255.255

 

interface Ethernet0/0

 ip address 10.10.13.1 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.17.1 255.255.255.0

 

router eigrp 10

 network 10.10.0.0 0.0.255.255

 

router bgp 10

 bgp log-neighbor-changes

 

 neighbor 10.10.0.3 remote-as 10

 neighbor 10.10.0.3 update-source Loopback0

 neighbor 10.10.0.3 next-hop-self

 neighbor 10.10.0.3 send-community

 

 neighbor 10.10.0.4 remote-as 10

 neighbor 10.10.0.4 update-source Loopback0

 neighbor 10.10.0.4 next-hop-self

 neighbor 10.10.0.4 send-community

 

 neighbor 192.168.17.7 remote-as 30

 neighbor 192.168.17.7 password my_password

 neighbor 192.168.17.7 ttl-security hops 1

 neighbor 192.168.17.7 send-community

 neighbor 192.168.17.7 route-map RMAP-SET_LOC_PREF in

 neighbor 192.168.17.7 route-map RMAP-SET_MED out

 

ip bgp-community new-format

 

ip community-list standard CLIST-10:110 permit 10:110

 

ip community-list standard CLIST-10:90 permit 10:90

 

ip prefix-list PLIST-AS10 seq 5 permit 172.10.0.0/22 le 32

 

route-map RMAP-SET_LOC_PREF permit 10

 match community CLIST-10:110

 set local-preference 110

 

route-map RMAP-SET_LOC_PREF permit 20

 match community CLIST-10:90

 set local-preference 90

route-map RMAP-SET_LOC_PREF permit 30

 

route-map RMAP-SET_MED permit 10

 match ip address prefix-list PLIST-AS10

 set metric 1000

route-map RMAP-SET_MED permit 20

 

R2:

hostname R2

 

interface Loopback0

 ip address 10.10.0.2 255.255.255.255

 

interface Ethernet0/0

 ip address 10.10.24.2 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.27.2 255.255.255.0

 

interface Ethernet0/2

 ip address 192.168.28.2 255.255.255.0

 

router eigrp 10

 network 10.10.0.0 0.0.255.255

 

router bgp 10

 bgp log-neighbor-changes

 

 neighbor 10.10.0.3 remote-as 10

 neighbor 10.10.0.3 update-source Loopback0

 neighbor 10.10.0.3 next-hop-self

 neighbor 10.10.0.3 send-community

 

 neighbor 10.10.0.4 remote-as 10

 neighbor 10.10.0.4 update-source Loopback0

 neighbor 10.10.0.4 next-hop-self

 neighbor 10.10.0.4 send-community

 

 neighbor 192.168.27.7 remote-as 30

 neighbor 192.168.27.7 password my_password

 neighbor 192.168.27.7 ttl-security hops 1

 neighbor 192.168.27.7 send-community

 neighbor 192.168.27.7 route-map RMAP-SET_LOC_PREF in

 neighbor 192.168.27.7 route-map RMAP-SET_MED out

 

 neighbor 192.168.28.8 remote-as 40

 neighbor 192.168.28.8 password my_password

 neighbor 192.168.28.8 ttl-security hops 1

 neighbor 192.168.28.8 send-community

 neighbor 192.168.28.8 route-map RMAP-SET_LOC_PREF in

 

ip bgp-community new-format

 

ip community-list standard CLIST-10:110 permit 10:110

 

ip community-list standard CLIST-10:90 permit 10:90

 

ip prefix-list PLIST-AS10 seq 5 permit 172.10.0.0/22 le 32

 

route-map RMAP-SET_LOC_PREF permit 10

 match community CLIST-10:110

 set local-preference 110

route-map RMAP-SET_LOC_PREF permit 20

 match community CLIST-10:90

 set local-preference 90

route-map RMAP-SET_LOC_PREF permit 30

 

route-map RMAP-SET_MED permit 10

 match ip address prefix-list PLIST-AS10

 set metric 500

route-map RMAP-SET_MED permit 20

 

R3:

hostname R3

 

interface Loopback0

 ip address 10.10.0.3 255.255.255.255

 

interface Ethernet0/0

 ip address 10.10.13.3 255.255.255.0

 

interface Ethernet0/1

 ip address 10.10.35.3 255.255.255.0

 

interface Ethernet0/2

 ip address 10.10.34.3 255.255.255.0

 

router eigrp 10

 network 10.10.0.0 0.0.255.255

 

router bgp 10

 bgp cluster-id 10.10.0.0

 bgp log-neighbor-changes

 

 neighbor PGROUP-INTERNAL peer-group

 neighbor PGROUP-INTERNAL remote-as 10

 neighbor PGROUP-INTERNAL update-source Loopback0

 neighbor PGROUP-INTERNAL route-reflector-client

 neighbor PGROUP-INTERNAL send-community

 

 neighbor 10.10.0.1 peer-group PGROUP-INTERNAL

 

 neighbor 10.10.0.2 peer-group PGROUP-INTERNAL

 

 neighbor 10.10.0.4 remote-as 10

 neighbor 10.10.0.4 update-source Loopback0

 neighbor 10.10.0.4 send-community

 

 neighbor 10.10.0.5 peer-group PGROUP-INTERNAL

 

 neighbor 10.10.0.6 peer-group PGROUP-INTERNAL

 

ip bgp-community new-format

 

R4:

hostname R4

 

interface Loopback0

 ip address 10.10.0.4 255.255.255.255

 

interface Loopback1

 ip address 172.10.0.4 255.255.255.0

 

interface Loopback2

 ip address 172.10.1.4 255.255.255.0

 

interface Loopback3

 ip address 172.10.2.4 255.255.255.0

 

interface Loopback4

 ip address 172.10.3.4 255.255.255.0

 

interface Ethernet0/0

 ip address 10.10.24.4 255.255.255.0

 

interface Ethernet0/1

 ip address 10.10.46.4 255.255.255.0

 

interface Ethernet0/2

 ip address 10.10.34.4 255.255.255.0

 

router eigrp 10

 network 10.10.0.0 0.0.255.255

 network 172.10.0.0

 

router bgp 10

 bgp cluster-id 10.10.0.0

 bgp log-neighbor-changes

 

 network 172.10.0.0 mask 255.255.255.0

 network 172.10.1.0 mask 255.255.255.0

 network 172.10.2.0 mask 255.255.255.0

 network 172.10.3.0 mask 255.255.255.0

 

 neighbor PGROUP-INTERNAL peer-group

 neighbor PGROUP-INTERNAL remote-as 10

 neighbor PGROUP-INTERNAL update-source Loopback0

 neighbor PGROUP-INTERNAL route-reflector-client

 neighbor PGROUP-INTERNAL send-community

 

 neighbor 10.10.0.1 peer-group PGROUP-INTERNAL

 

 neighbor 10.10.0.2 peer-group PGROUP-INTERNAL

 

 neighbor 10.10.0.3 remote-as 10

 neighbor 10.10.0.3 update-source Loopback0

 neighbor 10.10.0.3 send-community

 

 neighbor 10.10.0.5 peer-group PGROUP-INTERNAL

 

 neighbor 10.10.0.6 peer-group PGROUP-INTERNAL

 

ip bgp-community new-format

 

R5:

hostname R5

 

interface Loopback0

 ip address 10.10.0.5 255.255.255.255

 

interface Ethernet0/0

 ip address 10.10.35.5 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.59.5 255.255.255.0

 

router eigrp 10

 network 10.10.0.0 0.0.255.255

 

router bgp 10

 bgp log-neighbor-changes

 

 neighbor 10.10.0.3 remote-as 10

 neighbor 10.10.0.3 update-source Loopback0

 neighbor 10.10.0.3 next-hop-self

 neighbor 10.10.0.3 send-community

 

 neighbor 10.10.0.4 remote-as 10

 neighbor 10.10.0.4 update-source Loopback0

 neighbor 10.10.0.4 next-hop-self

 neighbor 10.10.0.4 send-community

 

 neighbor 192.168.59.9 remote-as 20

 neighbor 192.168.59.9 password my_password

 neighbor 192.168.59.9 ttl-security hops 1

 neighbor 192.168.59.9 send-community

 neighbor 192.168.59.9 route-map RMAP-SET_LOC_PREF in

 

ip bgp-community new-format

 

ip community-list standard CLIST-10:110 permit 10:110

 

ip community-list standard CLIST-10:90 permit 10:90

 

route-map RMAP-SET_LOC_PREF permit 10

 match community CLIST-10:110

 set local-preference 110

route-map RMAP-SET_LOC_PREF permit 20

 match community CLIST-10:90

 set local-preference 90

route-map RMAP-SET_LOC_PREF permit 30

 

R6:

hostname R6

 

interface Loopback0

 ip address 10.10.0.6 255.255.255.255

 

interface Ethernet0/0

 ip address 10.10.46.6 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.106.6 255.255.255.0

 

router eigrp 10

 network 10.10.0.0 0.0.255.255

 

router bgp 10

 bgp log-neighbor-changes

 

 neighbor 10.10.0.3 remote-as 10

 neighbor 10.10.0.3 update-source Loopback0

 neighbor 10.10.0.3 next-hop-self

 neighbor 10.10.0.3 send-community

 

 neighbor 10.10.0.4 remote-as 10

 neighbor 10.10.0.4 update-source Loopback0

 neighbor 10.10.0.4 next-hop-self

 neighbor 10.10.0.4 send-community

 

neighbor 192.168.106.10 remote-as 20

 neighbor 192.168.106.10 password my_password

 neighbor 192.168.106.10 ttl-security hops 1

 neighbor 192.168.106.10 send-community

 neighbor 192.168.106.10 route-map RMAP-SET_LOC_PREF in

 

ip bgp-community new-format

 

ip community-list standard CLIST-10:110 permit 10:110

 

ip community-list standard CLIST-10:90 permit 10:90

 

route-map RMAP-SET_LOC_PREF permit 10

 match community CLIST-10:110

 set local-preference 110

route-map RMAP-SET_LOC_PREF permit 20

 match community CLIST-10:90

 set local-preference 90

route-map RMAP-SET_LOC_PREF permit 30

 

R7:

hostname R7

 

interface Loopback0

 ip address 10.30.0.7 255.255.255.255

 

interface Loopback1

 ip address 172.30.0.7 255.255.255.0

 

interface Loopback2

 ip address 172.30.1.7 255.255.255.0

 

interface Loopback3

 ip address 172.30.2.7 255.255.255.0

 

interface Ethernet0/0

 ip address 192.168.17.7 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.27.7 255.255.255.0

 

interface Ethernet0/2

 ip address 192.168.78.7 255.255.255.0

 

interface Ethernet0/3

 ip address 192.168.127.7 255.255.255.0

 

router bgp 30

 bgp log-neighbor-changes

 

aggregate-address 172.30.0.0 255.255.252.0 summary-only

 

 network 172.30.0.0 mask 255.255.255.0

 network 172.30.1.0 mask 255.255.255.0

 network 172.30.2.0 mask 255.255.255.0

 network 172.30.3.0 mask 255.255.255.0

 

 neighbor 192.168.17.1 remote-as 10

 neighbor 192.168.17.1 password my_password

 neighbor 192.168.17.1 ttl-security hops 1

 neighbor 192.168.17.1 send-community

 neighbor 192.168.17.1 remove-private-as

 

 neighbor 192.168.27.2 remote-as 10

 neighbor 192.168.27.2 password my_password

 neighbor 192.168.27.2 ttl-security hops 1

 neighbor 192.168.27.2 send-community

 

 neighbor 192.168.78.8 remote-as 40

 neighbor 192.168.78.8 send-community

 neighbor 192.168.78.8 remove-private-as

 neighbor 192.168.78.8 route-map RMAP-SET_PREPEND out

 

 neighbor 192.168.127.12 remote-as 65001

 neighbor 192.168.127.12 password my_password

 neighbor 192.168.127.12 ttl-security hops 1

 neighbor 192.168.127.12 send-community

 neighbor 192.168.127.12 default-originate

 

ip bgp-community new-format

 

ip prefix-list PLIST-AS30 seq 5 permit 172.30.0.0/22 le 32

 

route-map RMAP-SET_PREPEND permit 10

 match ip address prefix-list PLIST-AS30

 set as-path prepend 30 30 30 30 30

route-map RMAP-SET_PREPEND permit 20

 

R8:

hostname R8

 

interface Loopback0

 ip address 10.40.0.8 255.255.255.255

 

interface Loopback1

 ip address 172.40.0.8 255.255.255.0

 

interface Loopback2

 ip address 172.40.1.8 255.255.255.0

 

interface Loopback3

 ip address 172.40.2.8 255.255.255.0

 

interface Loopback4

 ip address 172.40.3.8 255.255.255.0

 

interface Ethernet0/0

 ip address 192.168.89.8 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.108.8 255.255.255.0

 

interface Ethernet0/2

 ip address 192.168.78.8 255.255.255.0

 

interface Ethernet0/3

 ip address 192.168.28.8 255.255.255.0

 

router bgp 40

 bgp log-neighbor-changes

 

 network 172.40.0.0 mask 255.255.255.0

 network 172.40.1.0 mask 255.255.255.0

 network 172.40.2.0 mask 255.255.255.0

 network 172.40.3.0 mask 255.255.255.0

 

 neighbor 192.168.28.2 remote-as 10

 neighbor 192.168.28.2 password my_password

 neighbor 192.168.28.2 ttl-security hops 1

 neighbor 192.168.28.2 send-community

 

 neighbor 192.168.78.7 remote-as 30

 neighbor 192.168.78.7 send-community

 neighbor 192.168.78.7 route-map RAMP-SET_COMMUN out

 

 neighbor 192.168.89.9 remote-as 20

 neighbor 192.168.89.9 send-community

 neighbor 192.168.89.9 route-map RMAP-SET_WEIGHT_HIGH in

 

 neighbor 192.168.108.10 remote-as 20

 neighbor 192.168.108.10 send-community

 neighbor 192.168.108.10 route-map RMAP-SET_WEIGHT_LOW in

 

ip bgp-community new-format

 

ip prefix-list PLIST-AS20 seq 5 permit 172.20.0.0/22 le 32

 

ip prefix-list PLIST-AS40 seq 5 permit 172.40.0.0/22 le 32

 

route-map RAMP-SET_COMMUN permit 10

 match ip address prefix-list PLIST-AS40

 set community 10:110 additive

route-map RAMP-SET_COMMUN permit 20

 

route-map RMAP-SET_WEIGHT_LOW permit 10

 match ip address prefix-list PLIST-AS20

 set weight 1024

route-map RMAP-SET_WEIGHT_LOW permit 20

 

route-map RMAP-SET_WEIGHT_HIGH permit 10

 match ip address prefix-list PLIST-AS20

 set weight 2048

route-map RMAP-SET_WEIGHT_HIGH permit 20

 

R9:

hostname R9

 

interface Loopback0

 ip address 10.20.0.9 255.255.255.255

 

interface Ethernet0/0

 ip address 10.20.109.9 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.59.9 255.255.255.0

 

interface Ethernet0/2

 ip address 192.168.89.9 255.255.255.0

 

interface Ethernet0/3

 ip address 10.20.119.9 255.255.255.0

 ip summary-address eigrp 20 0.0.0.0 0.0.0.0

 

router eigrp 20

 network 10.20.0.0 0.0.255.255

 

router bgp 20

 bgp log-neighbor-changes

 

 network 172.20.0.0 mask 255.255.255.0

 network 172.20.1.0 mask 255.255.255.0

 network 172.20.2.0 mask 255.255.255.0

 network 172.20.3.0 mask 255.255.255.0

 

 neighbor 10.20.0.10 remote-as 20

 neighbor 10.20.0.10 update-source Loopback0

 neighbor 10.20.0.10 next-hop-self

 neighbor 10.20.0.10 send-community

 

 neighbor 192.168.59.5 remote-as 10

 neighbor 192.168.59.5 password my_password

 neighbor 192.168.59.5 ttl-security hops 1

 neighbor 192.168.59.5 send-community

 neighbor 192.168.59.5 route-map RMAP-SET_LOC_PREF_LOW in

 neighbor 192.168.59.5 filter-list 1 out

 

 neighbor 192.168.89.8 remote-as 40

 neighbor 192.168.89.8 send-community

 neighbor 192.168.89.8 route-map RMAP-SET_LOC_PREF_HIGH in

 neighbor 192.168.89.8 filter-list 1 out

 

ip bgp-community new-format

 

ip as-path access-list 1 permit ^$

 

ip prefix-list PLIST-AS30 seq 5 permit 172.30.0.0/22 le 32

 

route-map RMAP-SET_LOC_PREF_LOW permit 10

 match ip address prefix-list PLIST-AS30

 set local-preference 50

route-map RMAP-SET_LOC_PREF_LOW permit 20

 

route-map RMAP-SET_LOC_PREF_HIGH permit 10

 match ip address prefix-list PLIST-AS30

 set local-preference 150

route-map RMAP-SET_LOC_PREF_HIGH permit 20

 

R10:

hostname R10

 

interface Loopback0

 ip address 10.20.0.10 255.255.255.255

 

interface Ethernet0/0

 ip address 10.20.109.10 255.255.255.0

 

interface Ethernet0/1

 ip address 192.168.106.10 255.255.255.0

 

interface Ethernet0/2

 ip address 192.168.108.10 255.255.255.0

 

interface Ethernet0/3

 ip address 10.20.111.10 255.255.255.0

 ip summary-address eigrp 20 0.0.0.0 0.0.0.0

 

router eigrp 20

 network 10.20.0.0 0.0.255.255

 

router bgp 20

 bgp log-neighbor-changes

 

 network 172.20.0.0 mask 255.255.255.0

 network 172.20.1.0 mask 255.255.255.0

 network 172.20.2.0 mask 255.255.255.0

 network 172.20.3.0 mask 255.255.255.0

 

 neighbor 10.20.0.9 remote-as 20

 neighbor 10.20.0.9 update-source Loopback0

 neighbor 10.20.0.9 next-hop-self

 neighbor 10.20.0.9 send-community

 

 neighbor 192.168.106.6 remote-as 10

 neighbor 192.168.106.6 password my_password

 neighbor 192.168.106.6 ttl-security hops 1

 neighbor 192.168.106.6 send-community

 neighbor 192.168.106.6 route-map RMAP-SET_LOC_PREF_LOW in

 neighbor 192.168.106.6 filter-list 1 out

 

 neighbor 192.168.108.8 remote-as 40

 neighbor 192.168.108.8 send-community

 neighbor 192.168.108.8 route-map RMAP-SET_LOC_PREF_HIGH in

 neighbor 192.168.108.8 filter-list 1 out

 

ip bgp-community new-format

 

ip as-path access-list 1 permit ^$

 

ip prefix-list PLIST-AS30 seq 5 permit 172.30.0.0/22 le 32

 

route-map RMAP-SET_LOC_PREF_LOW permit 10

 match ip address prefix-list PLIST-AS30

 set local-preference 50

route-map RMAP-SET_LOC_PREF_LOW permit 20

 

route-map RMAP-SET_LOC_PREF_HIGH permit 10

 match ip address prefix-list PLIST-AS30

 set local-preference 150

route-map RMAP-SET_LOC_PREF_HIGH permit 20

 

R11:

hostname R11

 

interface Loopback0

 ip address 10.20.0.11 255.255.255.255

 

interface Loopback1

 ip address 172.20.0.11 255.255.255.0

 

interface Loopback2

 ip address 172.20.1.11 255.255.255.0

 

interface Loopback3

 ip address 172.20.2.11 255.255.255.0

 

interface Loopback4

 ip address 172.20.3.11 255.255.255.0

 

interface Ethernet0/0

 ip address 10.20.119.11 255.255.255.0

 

interface Ethernet0/1

 ip address 10.20.111.11 255.255.255.0

 

router eigrp 20

 network 10.20.0.0 0.0.255.255

 network 172.20.0.0

 

R12:

hostname R12

 

interface Loopback0

 ip address 10.65.0.12 255.255.255.0

 

interface Loopback1

 ip address 172.30.3.12 255.255.255.0

 

interface Loopback2

 ip address 172.65.0.12 255.255.255.0

 

interface Ethernet0/0

 ip address 192.168.127.12 255.255.255.0

 

router bgp 65001

 bgp log-neighbor-changes

 

network 172.30.3.0 mask 255.255.255.0

 network 172.65.0.0 mask 255.255.255.0

 

 neighbor 192.168.127.7 remote-as 30

 neighbor 192.168.127.7 password my_password

 neighbor 192.168.127.7 ttl-security hops 1

 neighbor 192.168.127.7 send-community

 neighbor 192.168.127.7 distribute-list ACL-DEFAULT_ROUTE in

 neighbor 192.168.127.7 route-map RMAP-NO_EXPORT out

 

ip bgp-community new-format

 

ip access-list standard ACL-DEFAULT_ROUTE

 permit 0.0.0.0

 

ip access-list extended ACL-NO_EXPORT

 permit ip host 172.65.0.0 host 255.255.255.0

 

route-map RMAP-NO_EXPORT permit 10

 match ip address ACL-NO_EXPORT

 set community no-export

route-map RMAP-NO_EXPORT permit 20

Share

One Response to BGP LAB Scenario

  1. thanks for your work! Regards raffa

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: